# Yarn PnP set up

Install Yarn:

yarn init -2

Update .gitignore:

.yarn/*
!.yarn/cache
!.yarn/patches
!.yarn/plugins
!.yarn/releases
!.yarn/sdks
!.yarn/versions

Update .prettierignore:

/.pnp.cjs
/.yarn/

Ensure .yarnrc.yml has pnp nodeLinker:

nodeLinker: pnp

Add VSCode editor integration:

yarn add --dev typescript
yarn dlx @yarnpkg/sdks vscode

Sources: